I think, that we should convert all unit configs from array to classes form.
This will give us such immediate benefits:
- all common unit config settings, that are copied from one unit config to another will be located in parent class (saves space);
- all unit config setting names will be automatically suggested by Zend, and this will eliminate most of setting name typing errors;
- we will have a list of all possible unit config settings with their description, purpose and usage examples.
We should create base class for unit configs where all mentioned above. I think, that all unit configs (system and user-made) should be named the same way and need to use some prefix (along with suffix as usual), that will prevent them from appearing in class-name auto-complete dialogs at least user really wants them to be there.
Unit config class name could be formed by coding standards using prefix-name, declared in this config. For example "ucUserConfig" (for prefix "user"), "ucAgentConfig" (for prefix "agent"), "ucCustomSection" (for prefix "custom-section") and so on.