Child pages
  • [debugger] Remove excessive Memcache output from debugger [5.2.1]
Skip to end of metadata
Go to start of metadata

Currently Memcache-related activity is represented by too much detail in the debugger report which makes it hard to use the report overall.

For a single key reading we have 3 records in debugger that looks like this:

r18: Restoring key "site_serial:1911584608:1:permissions[%GPermSerial%]:in-commerce:gift-certificates.view|1|0|11,15_rebuild" resulted []
r18: Restoring key "site_serial:1911584608:1:permissions[%GPermSerial%]:in-commerce:gift-certificates.view|1|0|11,15_serials" resulted [permissions[GPermSerial=]:in-commerce:gift-certificates.view|1|0|11,15]
r19: Restoring key "site_serial:1911584608:1:permissions[%GPermSerial%]:in-commerce:gift-certificates.view|1|0|11,15" resulted [1]

Solution

  1. remove 1st and 2nd entries completely (or don't show them by default, but if somebody wants to debug Memcache they can enable special new flag)
  2. remove site_serial:1911584608:1: part from key name because it's always the same.

After making these changes for exactly same single Memcache key read operation output in debugger would be:

r19: Restoring key "permissions[%GPermSerial%]:in-commerce:gift-certificates.view|1|0|11,15" resulted [1]

Related Tasks