Child pages
  • [install] The "Internal Server Error" on "DB config" installation step [5.2.1]
Skip to end of metadata
Go to start of metadata

The Install as fail when adding in Root password.. then after that it goes to 500 error

  • PHP version: 5.5
  • In-Portal version: Lastest
  • Webserver OS: CentOS

I'm not sure what it can be there is no error logs from the server so can be a update issue?

Solution

Related Tasks

47 Comments

  1. - In-Portal version . Lastest

    Please specify exact version. This is useful, when this bug report is opened after next In-Portal versions, that don't have such bug, are released.

    then after that it goes to 500 error

    I'm presuming that is "Internal Server Error" page with "500" HTTP response code. If that is the case what error is logged in Web Server error/access log when it happens. If that is PHP Fatal Error of some kind, then it's logged in there for sure.

  2. In-portal 5.2.1

    as for the error no logs which don't make scene to me; so i'm going to look into it some more, keep this ticket open for now, but as i can say, there is no logs that shows.

    or any reason... after you run a install

  3. I was able to replicate the issue locally. Thank you.

    I've seen people using In-Portal 5.2.1 on PHP 5.5, but I wasn't sure if it can be installed using PHP 5.5 as well. Probably they've installed it using PHP 5.4 or less and then upgraded to PHP 5.5.

  4. For me problem only happens, when installing from Google Chrome and "/system/config.php" file is absent. Installation from Firefox works fine.

    When error happens the "/system/config.php" file is created and if you:

    • drop all tables in database
    • open /core/install.php url again

    it will work fine.

    1. Okay, it's not working – so i guess i will try to make a fix which i thought i could find a way around but there is no other way i think who ever 

      • Apache 2.2
      • PHP 5.5
      • is what i have going
      1. Was /system/config.php file created when that error happened? If so, then what was it's content (replace credentials in there with user and pass).

        1. i removed the config, and re-uploaded the files all over just in case if i missed something, and still the same issue, so i will look into the config and try to install it the hard way :| HASH here i come!

          1. The solutions I've proposed before:

            1. keep the /system/config.php file + delete all db tables, that were created + try to reinstall
            2. if that doesn't help try removing all db tables + doing reinstalling from Firefox browser 

            Does either of them help?

            1. Nah, FireFox shows up blank after root install.. not sure it can be a issue with PHP5.5 it was working with my older domain, but now on the new domain its not even passing (big grin)

              1. Nah, FireFox shows up blank after root install.

                1. Was the /system/config.php file created?
                2. No errors in Apache error/access log files I presume.

                Maybe you record a video of how you're doing an install for me to see where it's crashing?

                1. yea, it was created .. and no logs mate.

                  1. And what is the content of /system/config.php file?

                    1. it was none, and then it made it with the same info of, Pass, username, DB, and etc.. i will do a screen record 

                       

                      1. When I've tried to reproduce the problem locally following /system/config.php file was created:

                        <?php
                        $_CONFIG['Misc']['WriteablePath'] = '/system';
                        $_CONFIG['Misc']['RestrictedPath'] = '/system/.restricted';
                        $_CONFIG['Misc']['WebsitePath'] = '/path/to/in-portal';
                        $_CONFIG['Misc']['Domain'] = 'my-domain.com';
                        $_CONFIG['Misc']['AdminDirectory'] = '/admin';
                        $_CONFIG['Misc']['AdminPresetsDirectory'] = '/admin';
                        $_CONFIG['Misc']['ApplicationClass'] = 'kApplication';
                        $_CONFIG['Misc']['ApplicationPath'] = '/core/kernel/application.php';
                        $_CONFIG['Misc']['CacheHandler'] = 'Memcache';
                        $_CONFIG['Misc']['MemcacheServers'] = 'localhost:11211';
                        $_CONFIG['Misc']['CompressionEngine'] = 'php';
                        $_CONFIG['Misc']['WebsiteCharset'] = 'utf-8';
                        $_CONFIG['Misc']['EnableSystemLog'] = '0';
                        $_CONFIG['Misc']['SystemLogMaxLevel'] = '5';
                        $_CONFIG['Misc']['TrustProxy'] = '0';
                        
                        
                        $_CONFIG['Database']['DBType'] = 'mysql';
                        $_CONFIG['Database']['DBHost'] = 'localhost';
                        $_CONFIG['Database']['DBName'] = 'db-name-here';
                        $_CONFIG['Database']['DBUser'] = 'db-user-here';
                        $_CONFIG['Database']['DBUserPassword'] = 'db-pass-here';
                        $_CONFIG['Database']['DBCollation'] = 'utf8_general_ci';
                        $_CONFIG['Database']['TablePrefix'] = '521_';
                        $_CONFIG['Database']['DBCharset'] = 'utf8';

                         

                        Now I realize, that I have Memcache Server running and it's enabled by default and all works. Probably there is something in the code, that fails, when Memcache server is missing.

                         

                        If possible please install Memcache server and all should work.

                        1. it worked before Memcache was not installed, as well JAVA all that.. i think its a file issue ... but i have the video done, now i just need to upload it

                           

                          1. It appears, that error is the same as in Fatal error with In-Portal 5.1.1 Beta1 on Windows where "_connect" function that doesn't exist is invoked. No error is logged anywhere because function is invoked before error reporting code runs (sad)

                            1. ah can be, well take your time on the script and i will start working on few other things on the theme

                              1. Try applying patch from http://qa.in-portal.org/D157 (download link is on the right) and doing reinstall.

                                The patch adds following code before last line in "SaveConfig" in "core/install/install_toolkit.php" file:

                                if ( function_exists('opcache_invalidate') ) {
                                	opcache_invalidate($this->INIFile);
                                }

                                Click on image to zoom.

                            2. https://vid.me/hDni took me some time to upload.. sorry for delay 

                              1. After doing the above change (patch apply I've described) I was able to get past DB credentials page and was able to enter root password as well.

                                So the issue is with new "opcode" cache that is enabled since PHP 5.5. In that aspect In-Portal 5.2.1 isn't compatible to PHP 5.5. However the patch I've mentioned is a change scheduled for In-Portal 5.2.2-B1 release which thanks to that would be PHP 5.5 compatible.

                                Was the issue fixed for you?

                                1. well the download link is not really working, atm, it just opens the file riff. so going try it on FireFox

                                  1. Yes, this is link to download file, but it might open in same window. I right click on it and click save to file.

                                    1. i know (smile) nah it's not working i will give up for now, and work on it later, atm i will work on the theme on localhost.. as its on 5.3 php so.. i will see what i can do to get to work one way or other

                                2. nah not working... patch was applyed but still blank after

                                  1. What you mean patch was already applied. The code I've mentioned isn't present in In-Portal 5.2.1. So after patch is applied you was able to get past DB config screen, but still blank screen after you enter root password?

                                  2. As you can see on [install] Fatal Error on Clean Install [5.2.2-B1] page I have xdebug enabled. It has nice feature to show many useful info on pages, that usually end up blank due an error.

                                    If possible please install Xdebug extension (see https://xdebug.org/) for your PHP.

                                    1. nah, it's not my server or i would haha, it's my CEO partner server that he use for hosting other clients.. so i can't really do much on it... 

                                       

                                      but i will work on it later (smile) maybe its time to upgrade all scripts into PHP5.5 into 5.6?

                                      1. Sever configurations vary and In-Portal must adapt to work on either server. This seems to be pretty unique server configuration. Anyway keep me updated with your findings.

                                        1. Yeah, i will try it on the UK server to see if that works. if not i will see about downgrading the PHP 5.4 to see if that can work.. but then again i would have to get a other server for only the Script i will be using (smile)

                                          1. Since In-Portal can run on PHP 5.5. I suggest installing it on your server and then just dumping DB and /system/config.php to client's server.

            2. http://prntscr.com/ap0lav

               

              even from Edge it can't get pass the 500 error :O okay well, i will look into it other way..

              1. I've meant a video of how you're doing the install, where you click what happens and so on. Screenshot doesn't help much here.

                This seems like some sort of server misconfiguration, which isn't a default for CentOS OS, because I've installed In-Portal on different CentOS versions without any issue.

  5. After several attempts to replicate it it stopped happening. This means unless it is happening 100% of the time we won't be able to fix it. Luckily there is a workaround that helps solve it for now.

  6. ah, alright, let me check on that (smile)

  7. Another thing to try:

    1. copy /tools/debug_sample.php to the /system folder
    2. rename /system/debug_sample.php into /system/debug.php
    3. open /system/debug.php for editing
    4. change 'DBG_IP' => '192.168.1.1/24;192.168.2.1/24;173.9.192.210', into 'DBG_IP' => '192.168.1.1/24;192.168.2.1/24;173.9.192.210;YOUR_IP_HERE', (replace "YOUR_IP_HERE" with your public IP, that you can find for example on https://www.whatismyip.com/ page)
    5. then during installation (after "DB configuration" step) you should be seeing In-Portal debugger toolbar that looks like this:
    6. hopefully on page that was blank you'll now have debugger toolbar as well
    7. if so, then click on "Show Debugger" button (see image above) and make a video where you scroll through that debugger report so that I can see all the info
  8. https://vid.me/hDni took me some time to upload.. sorry for delay

    I no longer can see the video today. Either you deleted it or that video hosting did that. You can also drop that video right into comment area and it will be stored in here as attachment to the page.

  9. okay, it's working, how ever, the 500 only doing it on the theme,

    Default Theme

     how ever the theme called "advanced theme" is the only one that is not giving the 500 error, and no logs. also, if you have time, can you do a custom work for a license for me?

    1. okay, it's working

      That doesn't explain how you fixed 500 error during installation. I guess enabling debugger along solved it. That's pretty bad workaround, because installation should work without debugger as well.

      how ever the theme called "advanced theme" is the only one that is not giving the 500 error, and no logs

      Not sure what you mean. The "advanced" theme uses most of available tags and allows to do lot of stuff. Other themes are very simple and useful CMS-only website creation.

      if you have time, can you do a custom work for a license for me?

      Sorry, but no. You can post questions on forums I guess and bug reports/feature suggestions here. But don't post huge features requests, like "I want social module" or "I want blogging module" because obviously it would take a lot of time to implement and you would be the only consumer for such a module.

  10. the Domain point was using a wrong format

    http://url.com/

    even tho it should be url.com/ only as it was using a non URL from what i saw... 

    After saw that, i edit out the URL pointer and made it into URL.com/ only

    if that helps

     

    as for the custom work. okay, well i thought u may have a license mod and as for with the BBcode can be upgraded

     

    i'm working on trying to make a few mods

  11. You say that when installing on http://url.com/core/install.php the suggested domain for installation, on "Domain Select" step was "http://url.com/" instead of "url.com" and that resulted in error.

    A screenshot would really help at this point (what domain was detected) compared to what URL was used to install In-Portal.

    1. Yes it does not make alot of scne to me, but after looking into it our US server does not use MOD_Rewrite at all but after installing that it gave URL error at the root password - where no errors logs was added... so i looked into it and after hours and hours it was a DOMAIN error at the install as it was using http://url.com/ even tho it should be url.com only.. but after toying around i got it to work the theme that i said still showed the 500 error but the only theme worked was the advanced theme so.. not sure on whats the deal with that ...

      1. The domain detection is done purely by looking at $_SERVER['HTTP_HOST'] variable in PHP. I guess it had "http://" in it, but I never saw such a problem before.

  12. it never happen to me first time as well, but yet it did this time

  13. is there a way to add a Google Ad or a HTML Ads into the system without getting PHP error in a footer? tpl area?

    1. This question isn't related in any way to originally discussed issue. Please post it with more details on the forums instead.

  14. yeah, keep forgetting that, sorry i will remove that (smile)

     

  15. Closing this discussion since problem stopped to happen for original reporter either.