Child pages
  • [cms] Internal page links from WYSIWYG editor sometimes aren't recognised [5.2.2-B1]
Skip to end of metadata
Go to start of metadata

CMS-wise fields in database are divided into 2 groups:

 

Where content is entered manually

Where content is entered using WYSIWYG editor
On page:

In template:
<inp2:m_RenderElement
	name="inp_edit_textarea"
	prefix="c"
	field="Description"
/> 
<inp2:m_RenderElement
	name="inp_edit_textarea"
	prefix="c"
	field="Description"
	allow_html="1"
/> 

For later the WYSIWYG editor can be opened by clicking special icon below field same (see arrow on image above). For WYSIWYG editor icon to be shown the allow_html="1" tag parameter needs to be specified, when rendering "inp_edit_textarea" or "inp_edit_textarea_ml" blocks.

Unfortunately that would only show the icon and nothing more. Get all WYSIWYG features to work on PHP side the 'using_fck' => 1', field option needs to be specified in unit config as well. That is what developers forget to do. That results in internal page links not being rendered correctly (e.g. doesn't transform from "@@554@@" into "http://...").

Solution

  1. change default value for "allow_html" block parameter from "" (empty string) to "auto"
  2. in the blocks using "allow_html" block parameter when it has "auto" value use value from "using_fck" field option instead

Related Discussions

Related Tasks

INP-1697 - Getting issue details... STATUS