Child pages
  • Better name for "Agents"
Skip to end of metadata
Go to start of metadata

Imported From:

Not too long ago we have added Agent functionality (Admin->Configuration->Website section) which allows you to schedule the Events to be run on specific time.

Perhaps, we have come across a better name for it now - Job Scheduler or Event Scheduler.

I am for new Event Scheduler name - it's more descriptive than current Agents, but at the same time it directly tells you what it does since in that section we are defining which Events should be run when in date/time. Job Scheduler is close but might be misleading since we actually do NOT have such term as a Jobs in In-Portal...

Please post your opinion which of two (original or 2 new ones) you like more and explain why (if not to hard for you).

Related Tasks

INP-794 - Getting issue details... STATUS


  1. I'd personnally see the things inside as "tasks", so I propose "Task

    2011/1/24 Dmitry A. <>

  2. Thanks for posting your opinion Phil.

    Do you know how the section works and which fields define what? The reason
    why I am asking that there is NO *Task *term or functionality in this
    section, while *Event *is what we actually schedule to run in specific time
    and repeat.

    I am just trying to follow though your idea.


  3. Event is good also, but I see an Event as something which happens, and a
    Task as something we make happening ;-)

    The perfect, but too long name would have been "maintenance schedule", as
    all these agents are maintening inportal, right?

    2011/1/24 Dmitry A. <>

  4. Not entirely true Phil.

    Events can be ANYTHING - import, update, cleanup, basically any ACTION. The
    purpose of this section is to be able to schedule Events that are programmed
    in In-Portal already (or to be programmed) to be triggered by the website on
    specific date/time.


  5. ok, anyway I like "Events" too :-)

    2011/1/24 Dmitry A. <>

  6. Here is more technical info.

    Events, are PHP methods, that are created to do something, e.g.

       - create record in database, when user hits "Save" button on edit form
       - import rss articles
       - login user and validate his password

    All events do something. Only difference is, who performs event invocation
    (calls it). It could be:

       - user (by specific button clicking on the page)
       - another event (one event requires additional action to be performed,
       that only other event know how to perform)
       - event scheduler (time-based event invocation)

    I'm for "Event Scheduler".

  7. thanks for clarification. Last one from me: "Regular Events" :)

    2011/1/24 Alexander Obuhovich <>

  8. Funny, but that was name of that section before it was renamed to "Agents".

  9. ah :)

    2011/1/24 Alexander Obuhovich <>

  10. Okay, creating a new task then!


  11. ok, and which name do we stick on?

    2011/1/25 Dmitry A. <>

  12. I believe we all agreed on "Event Scheduler" for the new name.

    Here is a new task for this:

    0000981: Rename Agents section to "Event Scheduler"

    INP-794 - Getting issue details... STATUS

    Alex, what is your opinion about renaming the other parts which involve
    Agents terms, ie:

    - Adding Agent "New Agent" => Scheduling New Event
    - Editing Agent "Agent Name" => Editing Event Schedule "Title of Event"


  13. This "Editing Event Schedule" sound a bit too complicated. That page is more
    alike Reoccurring Event Reminder that Microsort Outlook Calendar has.

    Based on this I propose "Adding Reoccurring Event" and
    "Editing Reoccurring Event".

    And section becomes "Reoccurring Events" instead of "Agents". This will 100%
    tell users, that events, listed here will be executed on regular basis,
    according reoccurring rules.

    Maybe "Editing Reoccurring Sequence" or something like this maybe even

  14. Using "microsoft-like" terminology is a good idea, as most end (admin) users
    are used of these terms, and we can also assume that Microsoft had thought a
    lot for choosing their words, why not using this work :-)

    2011/1/26 Alexander Obuhovich <>

  15. Ok, it's fine by me.

    I like - "Reoccurring Events" instead of Agent, but here is an idea.

    I believe we can easily improve this Reoccurring Events NOT always
    stay reoccurring - in some cases you want to schedule a task to be executed
    and then to disappear. I think we can add this functionality shortly - not
    too hard at all.

    This means that we should NOT limit ourselves to "Reoccurring Events" terms.
    I still think "Event Scheduler" is a broader and better terms here since we
    are scheduling the events to be run after all - some might be reoccurring,
    some not.

    What do you think?


  16. Then propose all changed phrase translations here.

  17. Hi all,

    Once again, I am proposing to change:

    1. Agents => Scheduled Events OR Event Scheduler (let me know which one you
    like more)
    2. Adding Agent "New Agent" => Scheduling New Event
    3. Editing Agent "Agent Name" => Editing Event Schedule "Title of Event"

    There might be a few more phrases that need to be changed, but they will be
    changed based on what we select for the main terms change.

    Thanks for your time and opinion!


  18. not too bad ;-)

    2011/1/26 Alexander Obuhovich <>

  19. Ok.

    Then event handler class would be renamed from "AgentEventHandler" to
    "EventScheduleEventHandler" :)

  20. In other words, we are ready to completely get rid of Agent term in
    translations and Code?

    Please confirm so I can update the task accordingly.


  21. Yes, I guess I just have to live with *Event*Schedule*Event*Handler class

  22. :D

    2011/1/29 Alexander Obuhovich <>

  23. Maybe it's already late to suggest, but I've see awesome name to give to
    agents on some website:
    *Scheduled Tasks*.

    So we have a task scheduled to run a given event at a specific times.
    Sounds very clean.

  24. well, it's so close to my very first proposal (Task Scheduler), that I
    can't say anything bad about it :)

    2011/11/14 Alexander Obuhovich <>