Child pages
  • [caching] Missing "Database Name" in Memory Cache Key
Skip to end of metadata
Go to start of metadata

Imported From: http://groups.google.com/group/in-portal-bugs/browse_thread/thread/d5b31a6294249b60#

Back in In-Portal 5.1.1 we have introduced the improvements to *Memory Cache Key* when separate memory cache was used for each developer. Original discussion for that was [caching] Separate memory cache for each developer

Looks like we have missed to add the Database Name to the equation for that Key which lead to the problem when multiple developers started to share the same Cache settings.

The fix is pretty simple - add the DB name to the key string.

Related Tasks

INP-830 - Getting issue details... STATUS

4 Comments

  1. It's good, that we have noticed that in time. That means, that such
    functionality is used enough to spot an error.

  2. I guess you need to add separator between table prefix and database name.

  3. Thanks for a hint - added a separator!

    New patch attached.

    DA

    Missing-Database-Name-in-Memory-Cache-Key.patch