Imported From: http://groups.google.com/group/in-portal-dev/browse_thread/thread/6ac2aa1ca9096712#

For quite some time we have talked (especially with Alex) about having Website Maintenance Mode.

At some point we have already created the task for this in In-Portal 5.2.0, but looks like there is NO discussion yet + some of the ideas needs to be finalized here before implementing.

Please review my description of the task and let me know if any notes/issue. ANY feedback is welcome:

I. Enabling "Maintenance Mode" 

Add 2 new options to "debug.php" file at the top

II. Managing "Maintenance Mode Messages"

  1. NEW "Maintenance Mode" section under Admin->Configuration->Advanced. Will have options:
    1. Front-End message (textarea, from from here to be put in to Template and shown when Maintenance mode is ON or there is NO DBG connection)
    2. Admin message  (textarea, from from here to be put in to Template and shown when Maintenance mode is ON or there is NO DBG connection Admin Login screen).

III. Front End behavior:

  1. END all Existing Sessions and LOGOUT users.
  2. AUTO-REDIRECT all New and Existing Users to special Page (generated from the Template) stating that site is in "Maintenance Mode" and displays System Message (defined via Site Configuration in Admin)
  3. EXCEPTIONS are IPs specified in Admin Config settings (see above)
  4. ALWAYS auto-redirect to this generated Front-end page if there is NO DB Connection (for some reason) even if my IP is in list of MAINTENANCE_MODE_IPS.

IV. Admin behavior:

  1. END all Existing Sessions and LOGOUT users.
  2. AUTO-REDIRECT to special Admin Page (generated from the Template) stating that site is in "Maintenance Mode" and displays System Message (defined via Site Configuration in Admin)
  3. EXCEPTIONS are IPs specified in Admin Config settings (see above)
  4. ALWAYS auto-redirect to this generated Admin page if there is NO DB Connection (for some reason) even if my IP is in list of MAINTENANCE_MODE_IPS.

Related Tasks